home cciesp cciedc cciesec ww ccies pt ccies juniper

CCIE SP Mini-Scenarios


I. Bridging and Switching
VTP, VLAN, Trunk, Spanning tree
Frame Relay, DLCI, FR multilink
ATM PVC, SVC, FR/ATM interworking
PPPoE

STP
PPPoE
PPPoE: MTU
PPPoE: PAP Authentication
PPPoE: CHAP Authentication
PPPoE: EAP Authentication
PPPoE: DHCP
PPPoE: IP Local Pool
PPPoE: AAA Authentication
PPPoE: Old Method
PPPoE: Old Method with DHCP
PPPoE: Old Method with DHCP and VRF
ATM Back-to-Back
FRF.5 Frame Relay-ATM Network Interworking
FRF.8 Frame Relay-ATM Service Interworking
Multilink Frame Relay (FRF.16.1)
ATM PVC: Point-to-Point with AAL5 SNAP Encapsulation
ATM PVC: Point-to-Point with AAL5 MUX Encapsulation
ATM PVC: Point-to-Point with AAL5 NLPID Encapsulation
ATM PVC: Multipoint Static Mapping
ATM PVC: Multipoint Dynamic Mapping
ATM PVC: PPPoA over Point-to-Point Subinterfaces
ATM PVC: PPPoA over Multipoint Subinterfaces
ATM PVC: Encapsulations
Back-to-back Frame-Relay (1)
Back-to-back Frame-Relay (2)
Back-to-back Frame-Relay (3)

II. IGP Routing
IS-IS, Level 1/2, Metric
OSPF, LSA, Area
Redistribution, Summarization, Filtering
Policy routing

IS-IS
IS-IS L2 to L1 Route Leaking
IS-IS: Single Area Design (1)
IS-IS: Single Area Design (2)
IS-IS: Single Area Design (3)
IS-IS: Hello Timers
IS-IS Basics (1)
IS-IS Basics (2)
IS-IS Authentication (1)
IS-IS Authentication (2)
IS-IS Authentication (3)
IS-IS: MTU Mismatch
IS-IS: Attached-bit Control Feature
IS-IS: Backdoor
IS-IS: Backdoor (2)
IS-IS: Adjacency Filter
IS-IS: Priority Prefix
IS-IS: Point-to-Point
IS-IS: Mesh Groups
OSPF LSAs
OSPF Stub Areas
OSPF NSSA Areas
OSPF Summarization
OSPF Filtering
OSPF over mGRE Tunnels
Redistribution (1)
Redistribution (2)
Redistribution (3)

III. EGP Routing
IBGP, EBGP
BGP attributes
Confederation, Route reflector
Synchronization, Aggregation, Stability
Redistribution, Filtering
Multipath

BGP Attributes: Weight
BGP Attributes: Local Preference
BGP Attributes: Origin
BGP Attributes: AS Path
BGP Attributes: MED
BGP Attributes: MED (bgp always-compare-med)
BGP Attributes: MED (bgp bestpath med missing-as-worst)
BGP Attributes: MED (bgp bestpath med confed)
BGP Attributes: Cost Community
BGP Best Path: IGP
BGP Best Path: Router ID
BGP Multipath
BGP Link Bandwidth
BGP Local-AS Feature
BGP No-Prepend Feature
BGP Dual Replace-AS Feature
BGP Dual Replace-AS Feature (2)
BGP Dual AS Feature

IV. SP Multicast
PIM-SM, PIM-DM, SSM, PIM-BIDIR, IGMP
Auto RP, Static RP, BSR, Anycast RP
MP-BGP for multicast, MSDP

PIM-DM
PIM-SM (Static RP)
PIM-SM (Auto RP) (1)
PIM-SM (Auto RP) (2)
PIM-SM (Auto RP) (3)
PIM-SM (BSR)
PIM SSM
PIM BIDIR (Static RP)
RP Anycast (Static RP)
PIM Security (1)
PIM Security (2)
PIM Security (3)
PIM Auto-RP Filter
Interdomain Multicast (MSDP)
Interdomain Multicast (MSDP+MBGP)
Interdomain Multicast (MSDP+MRoute)

V. MPLS
Label distribution, LDP/ TDP
Label filtering, Label merging, Multipath
MPLS COS
MPLS Netflow
MPLS over ATM
MPLS Traffic Engineering

Cell Mode MPLS
Back-to-back Cell Mode MPLS
Cell Mode MPLS Over VCs
Frame Mode MPLS
MPLS MTU
MPLS NetFlow
BGP Free Core
MPLS Static Labels
LDP Label Filtering
LDP Advertise Label
LDP Session Protection
MPLS TE
MPLS Traffic Engineering: Load Sharing
MPLS Traffic Engineering: Affinity
MPLS VPN TE
MPLS Traffic Engineering: Interarea Tunnels (OSPF)
MPLS Traffic Engineering: Interarea Tunnels (IS-IS)
MPLS Traffic Engineering: Optimization (1)
MPLS Traffic Engineering: Optimization (2)
MPLS Traffic Engineering: Optimization (3)
MPLS Traffic Engineering: Forwarding Adjacency (IS-IS)
MPLS Traffic Engineering: Forwarding Adjacency (OSPF)
MPLS Multipath

VI. L3/L2 VPN
MPLS VPN, MP-iBGP
PE-CE routing, RIPv2, OSPF, EIGRP, Static, ISIS, EBGP
BGP Extended Community
Inter AS MPLS VPN
Carrier Supporting Carrier
VRF-Lite, VRF Select
Multicast MPLS VPN
GRE, multipoint GRE
AToM, L2TPv3
802.QinQ

Route Leaking
Route Leaking Between VRFs
Redistribution inside a VRF
PE-CE Routing (Static)
PE-CE Routing (RIPv2)
PE-CE Routing (RIPv2 Sub-Optimal Routing)
PE-CE Routing (RIPv2 Optimal Routing)
PE-CE Routing (EIGRP Same AS)
PE-CE Routing (EIGRP Different AS)
PE-CE Routing (EIGRP Sub-Optimal Routing)
PE-CE Routing (EIGRP Site of Origin)
PE-CE Routing (OSPF Same Process ID)
PE-CE Routing (OSPF Different Process ID)
PE-CE Routing (OSPF Domain-Id)
PE-CE Routing (OSPF Sub-Optimal Routing)
PE-CE Routing (OSPF Sham-Link)
Sham-Link Intra-AS
Sham-Link Intra-AS (2)
Sham-Link Inter-AS with eBGP
Sham-Link Inter-AS with iBGP
PE-CE Routing (IS-IS)
MPLS VPN: VRF Over GRE
BGP Site of Origin
Inter-AS MPLS VPNs Option A (Back-to-back VRF at the ASBRs)
Inter-AS MPLS VPNs Option B (VPNv4 route exchange between ASBRs)
Inter-AS MPLS VPNs Option B (VPNv4 route exchange between ASBRs with Route-Target Rewrite)
Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange)
Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange with Route-Target Rewrite)
Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange with Route-Target Rewrite)
Carrier Supporting Carrier: Customer Carrier Not Running MPLS
Carrier Supporting Carrier: Customer Carrier Running MPLS
Carrier Supporting Carrier: Customer Carrier Providing MPLS VPN Service
Carrier Supporting Carrier: Customer Carrier Providing MPLS VPN Service (2)
VRF Select
VRF Selection with PBR
VRF Lite
Multicast VPN (with SSM in the Core)
Multicast VPN (with SM in the Core)
Multicast VPN Multiple PE's
Dynamic L3-VPNs over mGRE
Inter-AS Multicast VPNs Option A (Back-to-back VRF at the ASBRs)
Inter-AS Multicast VPNs Option C (VPNv4 between RR's)
Inter-AS Multicast VPNs Option C (VPNv4 between PE's)
Dynamic L3-VPNs over L2TPv3
AToM - Ethernet over MPLS (Router to Router Port Mode)
AToM - Ethernet over MPLS (Router to Router Vlan Mode)
AToM - Ethernet over MPLS (Router to Router Vlan Rewrite)
AToM - Ethernet over MPLS (Switch to Switch Vlan Mode)
AToM - Ethernet over MPLS (Switch to Switch Port Mode - QinQ)
AToM - Ethernet over MPLS (Switch to Switch Port Mode - Native)
AToM - Frame Relay over MPLS
AToM - Frame Relay over MPLS with a Frame-Relay Switch
AToM - Port Mode Frame Relay over MPLS
AToM - PPP over MPLS
AToM - HDLC over MPLS
AToM - ATM over MPLS (AAL5)
AToM - ATM over MPLS (Cell Relay)
L2TPv3 - Ethernet over L2TPv3 (Router to Router Port Mode)
L2TPv3 - Ethernet over L2TPv3 (Router to Router Vlan Mode)
L2TPv3 - Ethernet over L2TPv3 (Router to Router Vlan Rewrite)
L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Vlan Mode)
L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Port Mode - QinQ)
L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Port Mode - Native)
L2TPv3 - Frame Relay over L2TPv3
L2TPv3 - PPP over L2TPv3
L2TPv3 - HDLC over L2TPv3
L2TPv3 - ATM over L2TPv3 (AAL5)
L2TPv3 - ATM over L2TPv3 (Cell Relay)
Interworking: Ethernet-to-VLAN using AToM (bridged)
Interworking: Ethernet-to-VLAN using AToM (routed)
Interworking: FR-to-VLAN using AToM (bridged)
Interworking: FR-to-VLAN using AToM (routed)
Interworking: PPP-to-VLAN using AToM (bridged)
Interworking: PPP-to-VLAN using AToM (routed)
Interworking: ATM-to-VLAN using AToM (bridged)
Interworking: ATM-to-VLAN using AToM (routed)
Interworking: FR-to-PPP using AToM (bridged)
Interworking: FR-to-PPP using AToM (routed)
Interworking: FR-to-ATM using AToM (bridged)
Interworking: FR-to-ATM using AToM (routed)
Interworking: PPP-to-ATM using AToM (bridged)
Interworking: PPP-to-ATM using AToM (routed)
Interworking: Ethernet-to-VLAN using L2TPv3 (bridged)
Interworking: Ethernet-to-VLAN using L2TPv3 (routed)
Interworking: FR-to-VLAN using L2TPv3 (bridged)
Interworking: FR-to-VLAN using L2TPv3 (routed)
Interworking: PPP-to-VLAN using L2TPv3 (bridged)
Interworking: PPP-to-VLAN using L2TPv3 (routed)
Interworking: ATM-to-VLAN using L2TPv3 (bridged)
Interworking: ATM-to-VLAN using L2TPv3 (routed)
Interworking: FR-to-PPP using L2TPv3 (bridged)
Interworking: FR-to-PPP using L2TPv3 (routed)
Interworking: FR-to-ATM using L2TPv3 (bridged)
Interworking: FR-to-ATM using L2TPv3 (routed)
Interworking: PPP-to-ATM using L2TPv3 (bridged)
Interworking: PPP-to-ATM using L2TPv3 (routed)
Local Switching: Ethernet-to-Ethernet
Local Switching: VLAN-to-VLAN
Local Switching: FR-to-FR
Local Switching: ATM-to-ATM
Local Switching with Interworking: Ethernet-to-VLAN (bridged)
Local Switching with Interworking: Ethernet-to-VLAN (routed)
Local Switching with Interworking: FR-to-VLAN (bridged)
Local Switching with Interworking: FR-to-VLAN (routed)
AToM - Inter-AS L2-VPNs (Pseudo-Wire Switching)
AToM - L3VPNs over L2VPNs

VII. SP QoS and Security
DSCP/EXP, TOS, NBAR
Marking, Shaping, Policing
CAR, FRTS
WRQ, CBWFQ, LLQ, PQ, CQ
RED, WRED
LFI, cRTP
RSVP
ACL, RPF, Filtering
Routing update security
Common attacks

MPLS VPN QoS (Uniform Mode)
MPLS VPN QoS (Pipe Mode)
MPLS VPN QoS (Implicit Null)
MPLS VPN QoS (Explicit Null)
MPLS VPN QoS (Explicit-Null at the Managed CE)
MPLS VPN QoS (Traffic Engineering)
QoS Nested Policy-Maps
QoS Rate Limit Continue
QoS IP SLA
RSVP
uRPF (Old Style)
uRPF (New Style)
Smurf
Fraggle
LDP/TDP ACL
Remotely Triggered Black Hole (RTBH) Filtering Source-Based
Remotely Triggered Black Hole (RTBH) Filtering Destination-Based
Control Plane Policing (1)
Control Plane Policing (2)
Control Plane Policing (3)
QoS Policy Propagation with BGP (1)
QoS Policy Propagation with BGP (2)

VIII. High Availability
NSF, GLBP
Fast reroute, Link/Node protection
HSRP, VRRP

HSRP
VRRP
GLBP
MPLS TE Fast ReRoute (FRR)

IX. Management
SNMP, SYSLOG, RMON
Accounting
Netflow
NTP

SNMP
NTP
SSH
RMON
IP Accounting
NetFlow

STP



Topology:


Purpose: Play with port-priority and port-cost.

Dynamips .net file and configurations


PPPoE



Topology:


Purpose: Basic PPPoE configuration. Since PPPoE is not supported in 7200's SP Images, 3725's are used instead.

Dynamips .net file and configurations


PPPoE: MTU



Topology:


Purpose: PPPoE MTU Issues.

Comments:
PPPoE introduces 8 bytes of overhead.
PPP-over-Ethernet Session (6 bytes) + Point-to-Point Protocol (2 bytes).
It's recommended to set the MTU to 1492 bytes.

Dynamips .net file and configurations


PPPoE: PAP Authentication



Topology:


Purpose: Basic PPPoE configuration with PAP authentication.

Dynamips .net file and configurations


PPPoE: CHAP Authentication



Topology:


Purpose: Basic PPPoE configuration with CHAP authentication.

Dynamips .net file and configurations


PPPoE: EAP Authentication



Topology:


Purpose: Basic PPPoE configuration with EAP authentication.

Dynamips .net file and configurations


PPPoE: DHCP



Topology:


Purpose: Basic PPPoE configuration where the CE gets IP Address from DHCP server.

Dynamips .net file and configurations


PPPoE: IP Local Pool



Topology:


Purpose: Basic PPPoE configuration where the CE gets IP Address from IP Pool.

Dynamips .net file and configurations


PPPoE: AAA Authentication



Topology:


Purpose: Dealing with AAA Authentication.

Dynamips .net file and configurations


PPPoE: Old Method



Topology:


Purpose: PPPoE with VPDN Groups.

Dynamips .net file and configurations


PPPoE: Old Method with DHCP



Topology:


Purpose: PPPoE with VPDN Groups and DHCP.

Dynamips .net file and configurations


PPPoE: Old Method with DHCP and VRF



Topology:


Purpose: PPPoE with VPDN Groups, DHCP and VRF.

Dynamips .net file and configurations


ATM Back-to-Back



Topology:


Purpose: ATM back-to-back configuration.

Dynamips .net file and configurations


FRF.5 Frame Relay-ATM Network Interworking



Topology:


Purpose: Allows Frame Relay end users to communicate over an intermediate ATM network.

Comments:
Supported since 12.1(2)T on several platforms and feature sets.

Dynamips .net file and configurations


FRF.8 Frame Relay-ATM Service Interworking



Topology:


Purpose: Allows a Frame Relay end user to communicate with an ATM end user.

Comments:
Supported since 12.1(2)T on several platforms and feature sets.

Dynamips .net file and configurations


Multilink Frame Relay (FRF.16.1)



Topology:


Purpose: Aggregate multiple Frame-Relay Links.

Comments:
Not supported in 12.2S.

Dynamips .net file and configurations


ATM PVC: Point-to-Point with AAL5 SNAP Encapsulation



Topology:


Purpose: ATM PVC Encapsulations.

Comments:
Basic ATM PVC Point-to-point configuration.
IP OK, CLNS OK.

Dynamips .net file and configurations


ATM PVC: Point-to-Point with AAL5 MUX Encapsulation



Topology:


Purpose: ATM PVC Encapsulations.

Comments:
Basic ATM PVC Point-to-point configuration.
IP OK, CLNS NOK.

Dynamips .net file and configurations


ATM PVC: Point-to-Point with AAL5 NLPID Encapsulation



Topology:


Purpose: ATM PVC Encapsulations.

Comments:
Basic ATM PVC Point-to-point configuration.
IP OK, CLNS OK.

Dynamips .net file and configurations


ATM PVC: Multipoint Static Mapping



Topology:


Purpose: ATM PVC Multipoint.

Comments:
Basic ATM PVC Multipoint configuration.

Dynamips .net file and configurations


ATM PVC: Multipoint Dynamic Mapping



Topology:


Purpose: ATM PVC Multipoint.

Comments:
Basic ATM PVC Multipoint configuration.

Dynamips .net file and configurations


ATM PVC: PPPoA over Point-to-Point Subinterfaces



Topology:


Purpose: PPPoA configuration.

Comments:
Encapsulation is AAL5SNAP.

Dynamips .net file and configurations


ATM PVC: PPPoA over Multipoint Subinterfaces



Topology:


Purpose: PPPoA configuration.

Comments:
Encapsulation is AAL5SNAP.

Dynamips .net file and configurations


ATM PVC: Encapsulations



Topology:


Purpose: Playing with ATM encapsulations.

Dynamips .net file and configurations


Back-to-back Frame-Relay (1)



Topology:


Purpose: Back-to-back Frame-Relay.

Comments:
R1 simulates a FR Switch.

Dynamips .net file and configurations


Back-to-back Frame-Relay (2)



Topology:


Purpose: Back-to-back Frame-Relay.

Comments:
"no keepalive" technique.

Dynamips .net file and configurations


Back-to-back Frame-Relay (3)



Topology:


Purpose: Back-to-back Frame-Relay.

Comments:
"no keepalive" technique and DLCI mismatching.

Dynamips .net file and configurations


IS-IS



Topology:


Purpose: Simple IS-IS redistribution situation.

Comments:
PE2 redistributes connected into L2 and L1.

Dynamips .net file and configurations


IS-IS L2 to L1 Route Leaking



Topology:


Purpose: Domain-Wide Prefix Distribution (L2 to L1 Route Leaking).

Comments:
R2 redistributes L2 route into L1.

Dynamips .net file and configurations


IS-IS: Single Area Design (1)



Topology:


Purpose: IS-IS single area design issues.

Dynamips .net file and configurations


IS-IS: Single Area Design (2)



Topology:


Purpose: IS-IS single area design issues.

Dynamips .net file and configurations


IS-IS: Single Area Design (3)



Topology:


Purpose: IS-IS single area design issues.

Comments:
R3 only leaks R4-Lo0 and R5-Lo0 from L2 to L1.
R3 only leaks R1-Lo0 and R2-Lo0 from L1 to L2.

Dynamips .net file and configurations


IS-IS: Hello Timers



Topology:


Purpose: Understand IS-IS Hello Timers.

Comments:
Between R1 and R2:
L1 holdtime=1 s.
L2 holdtime=1 s.
L1 hellos=100 ms.
L2 hellos=200 ms.
Between R2 and R3.
R2 L1 and L2 holdtime=25 s (Non-DIS announced holdtime=hello-interval*hello-multiplier).
R3 L1 and L2 holdtime=5 s (DIS announced holdtime=hello-interval).
R2 L1 and L2 hellos=5 s (Non-DIS sends at hello-interval rate).
R3 L1 and L2 hellos=1 s (DIS sends at hello-interval/hello-multiplier rate).

Dynamips .net file and configurations


IS-IS Basics (1)



Topology:


Purpose: Understand IS-IS Areas and Adjacencies.

Comments:
All routers with default is-type.
R1 adjacencies: R2 (L1, L2), R4 (L1L2), R3 (L2).
R2 adjacencies: R1 (L1, L2), R5 (L1L2), R3 (L2).
R3 adjacencies: R1 (L2), R2 (L2), R6 (L1, L2).
R4 adjacencies: R1 (L1L2), R5 (L1, L2).
R5 adjacencies: R2 (L1L2), R4 (L1, L2).
R6 adjacencies: R3 (L1, L2).

Dynamips .net file and configurations


IS-IS Basics (2)



Topology:


Purpose: Understand IS-IS Areas and Adjacencies.

Comments:
R1/R2/R3 are L1L2, R4/R5 are L1, R6 is L2.
R1 adjacencies: R2 (L1, L2), R4 (L1), R3 (L2).
R2 adjacencies: R1 (L1, L2), R5 (L1), R3 (L2).
R3 adjacencies: R1 (L2), R2 (L2), R6 (L2).
R4 adjacencies: R1 (L1), R5 (L1).
R5 adjacencies: R2 (L1), R4 (L1).
R6 adjacencies: R3 (L2).

Dynamips .net file and configurations


IS-IS Authentication (1)



Topology:


Purpose: Understand IS-IS Old Style Authentication.

Comments:
R1/R2/R3 are L1L2, R4/R5 are L1, R6 is L2.
domain-password DOMAIN-1 (R1,R2,R3,R6).
area-password AREA-1 (R1,R2,R4,R5).
area-password AREA-2 (R3,R6).
isis password LEVEL-1 level-1 (R1,R2,R3,R4,R5).
isis password LEVEL-2 level-2 (R1,R2,R3,R6).
isis password LEVEL-1-2 (R1,R2,R4,R5).

Dynamips .net file and configurations


IS-IS Authentication (2)



Topology:


Purpose: Understand IS-IS New Style Authentication.

Comments:
R1/R2/R3 are L1L2, R4/R5 are L1, R6 is L2.
Process Level:.
authentication mode text level-1
authentication mode md5 level-2
authentication key-chain LEVEL-1 level-1
authentication key-chain LEVEL-2 level-2
LAN Interfaces:.
isis authentication mode text level-1
isis authentication mode md5 level-2
isis authentication key-chain LEVEL-1 level-1
isis authentication key-chain LEVEL-2 level-2
SERIAL Interfaces:.
isis authentication mode text
isis authentication key-chain LEVEL-1-2

Dynamips .net file and configurations


IS-IS Authentication (3)



Topology:


Purpose: IS-IS Authentication in 12.2T and 12.3T.

Dynamips .net file and configurations


IS-IS: MTU Mismatch



Topology:


Purpose: CLNS MTU Command.

Dynamips .net file and configurations


IS-IS: Attached-bit Control Feature



Topology:


Purpose: Clear ATT Bit.

Comments:
R2 sets the ATT bit if Area 49.0004 is present in the CLNS routing table.
R2 doesn't set the ATT bit if Area 49.0003 is present in the CLNS routing table.
Must enable "clns routing" and "clns router isis" otherwise the CLNS RT won't be populated.

Dynamips .net file and configurations


IS-IS: Backdoor



Topology:


Purpose: Clear ATT Bit.

Dynamips .net file and configurations


IS-IS: Backdoor (2)



Topology:


Purpose: Clear ATT Bit.

Dynamips .net file and configurations


IS-IS: Adjacency Filter



Topology:


Purpose: Control IS-IS Adjacencies.

Dynamips .net file and configurations


IS-IS: Priority Prefix



Topology:


Purpose: IS-IS Support for Priority-Driven IP Prefix RIB Installation.

Dynamips .net file and configurations


IS-IS: Point-to-Point



Topology:


Purpose: Integrated IS-IS Point-to-Point Adjacency over Broadcast Media.

Dynamips .net file and configurations


IS-IS: Mesh Groups



Topology:


Purpose: Optimize link-state packet (LSP) flooding in nonbroadcast multiaccess (NBMA) networks.

Dynamips .net file and configurations


OSPF LSAs



Topology:


Purpose: Understand OSPF LSAs.

Comments:
C1, C2 and C3 in Area 0.
C1 is an ABR.
R1 and R2 in Area 12.
R1 originates Type-1 LSA.
R2 originates Type-1 and Type-2 LSAs.
C1 originates Type-1, Type-3 and Type-4 LSAs.
C2 is an ASBR.
R3 running RIP.
C2 originates Type-1 and Type-5 LSAs.
C3 is a Backbone Router.
C3 originates Type-1 LSA.

Dynamips .net file and configurations


OSPF Stub Areas



Topology:


Purpose: Understand OSPF Stub and Totally Stubby Areas.

Comments:
C1, C2 and C3 in Area 0.
C1 is a Backbone Router.
C1 originates Type-1
C2 is an ASBR.
R3 running RIP.
C2 originates Type-1 and Type-5 LSAs.
C3 is an ABR.
R4 in Stub Area 4.
R5 in Totally Stubby Area 5.
R6 in Area 6.
C3 originates Type-1, Type-3 and Type-4 LSAs.
Type-4 and Type-5 LSAs are not propagated to Area 4.
Type-3, Type-4 and Type-5 LSAs are not propagated to Area 5 (except default route Type-3 LSA).
Type-3, Type-4 and Type-5 LSAs are propagated to Area 6.

Dynamips .net file and configurations


OSPF NSSA Areas



Topology:


Purpose: Understand OSPF NSSA and Totally Stubby NSSA Areas.

Comments:
C1, C2 and C3 in Area 0.
C1 is a Backbone Router.
C1 originates Type-1
C2 is an ASBR.
R3 running RIP.
C2 originates Type-1 and Type-5 LSAs.
C3 is an NSSA ABR.
R4 in NSSA Area 4.
R5 in NSSA Totally Stubby Area 5.
R6 in Area 6.
C3 originates Type-1, Type-3, Type-4 and Type-5 LSAs.
R4 originates Type-1 and Type-7 LSA's.
R5 originates Type-1 and Type-7 LSA's.
Type-4 and Type-5 LSAs are not propagated to Area 4.
Type-3, Type-4 and Type-5 LSAs are not propagated to Area 5 (except default route Type-3 LSA).
Type-3, Type-4 and Type-5 LSAs are propagated to Area 6.

Dynamips .net file and configurations


OSPF Summarization



Topology:


Purpose: Understand OSPF Summarization.

Comments:
C1, C2 and C3 in Area 0.
C1 is an ABR.
R1 in Area 1.
C2 is an ASBR.
R3 running RIP.
C3 is an ABR.
R6 in Area 6.
Area-range at the ABRs.
Summary-address at the ASBR.

Dynamips .net file and configurations


OSPF Filtering



Topology:


Purpose: OSPF ABR Type 3 LSA Filtering.

Comments:
C1, C2 and C3 in Area 0.
C1 is an ABR.
R1 in Area 1.
C2 is an ASBR.
R3 running RIP.
C3 is an ABR.
R6 in Area 6.
C1 filters R6-lo0 sent to area 1.
C1 filters R1-lo0 sent from area 1.

Dynamips .net file and configurations


OSPF over mGRE Tunnels



Topology:


Purpose: OSPF over mGRE.

Comments:
PE1,PE2 and PE3 become adjacent over the mGRE Tunnels.

Dynamips .net file and configurations


Redistribution (1)



Topology:


Purpose: Mutual Redistribution between OSPF and ISIS.

Comments:
R4 redistributes OSPF into ISIS L1.
R4 redistributes ISIS L1 and Connected into OSPF.
R4 prefers ISIS routes via ISIS.
R6 redistributes OSPF into ISIS L2.
R6 redistributes ISIS L2 and Connected into OSPF.
R6 prefers ISIS routes via ISIS.

Dynamips .net file and configurations


Redistribution (2)



Topology:


Purpose: Mutual Redistribution between OSPF and ISIS.

Comments:
R4 redistributes OSPF into ISIS L1.
R4 redistributes ISIS L1 and Connected into OSPF.
R4 prefers ISIS routes via ISIS.
R6 redistributes OSPF into ISIS L2.
R6 redistributes ISIS L2 and Connected into OSPF.
R6 prefers ISIS routes via ISIS.
R5 redistributes OSPF into ISIS L1L2.
R5 redistributes ISIS L1L2 and Connected into OSPF.
R5 prefers ISIS routes via ISIS.

Dynamips .net file and configurations


Redistribution (3)



Topology:


Purpose: Mutual Redistribution between OSPF and ISIS.

Comments:
L1 and L2 routes into OSPF.
OSPF into L1 and L2.
Connected into OSPF.
L2 into L1.

Dynamips .net file and configurations


BGP Attributes: Weight



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R4->R2->R1
R3->R4->R2->R1

Dynamips .net file and configurations


BGP Attributes: Local Preference



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R4->R2->R1
R3->R4->R2->R1

Dynamips .net file and configurations


BGP Attributes: Origin



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R4->R5->R6->R3->R2->R1
R5->R6->R3->R2->R1
R6->R3->R2->R1

Dynamips .net file and configurations


BGP Attributes: AS Path



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R4->R2->R1
R3->R1

Dynamips .net file and configurations


BGP Attributes: MED



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R4->R5->R6->R3->R2->R1
R5->R6->R3->R2->R1
R6->R3->R2->R1

Dynamips .net file and configurations


BGP Attributes: MED (bgp always-compare-med)



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R2-lo0:
R4->R5->R6->R3->R2
R5->R6->R3->R2
R6->R3->R2

Dynamips .net file and configurations


BGP Attributes: MED (bgp bestpath med missing-as-worst)



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R2-lo0:
R4->R5->R6->R3->R2
R5->R6->R3->R2
R6->R3->R2

Dynamips .net file and configurations


BGP Attributes: MED (bgp bestpath med confed)



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R2-lo0:
R4->R5->R6->R3->R2
R5->R6->R3->R2
R6->R3->R2

Dynamips .net file and configurations


BGP Attributes: Cost Community



Topology:


Purpose: BGP Attributes.

Comments:
Traffic flow to R1-lo0:
R5->R6->R3->R2->R1
Traffic flow to R3-lo0:
R5->R4->R1->R2->R3

Dynamips .net file and configurations


BGP Best Path: IGP



Topology:


Purpose: BGP Best Path.

Comments:
Traffic flow to R1-lo0:
R5->R6->R3->R2->R1

Dynamips .net file and configurations


BGP Best Path: Router ID



Topology:


Purpose: BGP Best Path.

Comments:
Traffic flow to R1-lo0:
R5->R6->R3->R2->R1

Dynamips .net file and configurations


BGP Multipath



Topology:


Purpose: Equal-cost load balancing.

Comments:
Traffic flow to R1-lo0:
Equally load-balanced from R5 to R4 and R6.

Dynamips .net file and configurations


BGP Link Bandwidth



Topology:


Purpose: Unequal-cost load balancing.

Comments:
Traffic flow to R1-lo0:
Unequally load-balanced from R5 to R4 and R6.

Dynamips .net file and configurations


BGP Local-AS Feature



Topology:


Purpose: To customize the AS_PATH attribute for routes received from an external Border Gateway Protocol (eBGP) neighbor.

Dynamips .net file and configurations


BGP No-Prepend Feature



Topology:


Purpose: Does not prepend the local autonomous system number to any routes received from the eBGP neighbor.

Dynamips .net file and configurations


BGP Replace-AS Feature



Topology:


Purpose: Replaces the real autonomous system number with the local autonomous system number in the eBGP updates.
The autonomous system number from the local BGP routing process is not prepended.

Dynamips .net file and configurations


BGP Replace-AS Feature (2)



Topology:


Purpose: Replaces the real autonomous system number with the local autonomous system number in the eBGP updates.
The autonomous system number from the local BGP routing process is not prepended.

Dynamips .net file and configurations


BGP Dual AS Feature



Topology:


Purpose: BGP Support for Dual AS Configuration for Network AS Migrations.

Dynamips .net file and configurations


PIM-DM



Topology:


Purpose: Understand PIM Dense Mode Operation.

Comments:
All routers running OSPF
All routers running PIM-DM.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.
(*, G) and (S, G) entries in every router.

Dynamips .net file and configurations


PIM-SM (Static RP)



Topology:


Purpose: Understand PIM Sparse Mode Operation with Static Rendezvous Point.

Comments:
All routers running OSPF
All routers running PIM-SM.
R3 is the RP.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.
(*, G) and (S, G) entries in every router.

Dynamips .net file and configurations


PIM-SM (Auto RP) (1)



Topology:


Purpose: Understand Auto RP Operation in Sparse-Mode Only environment.

Comments:
All routers running OSPF
All routers running PIM-SM.
R3 is the Auto RP and Mapping Agent.
224.0.1.39 - RP announcement.
224.0.1.40 - RP discovery.
R2 and R4 configured with "ip pim autorp listener".
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.

Dynamips .net file and configurations


PIM-SM (Auto RP) (2)



Topology:


Purpose: Understand Auto RP Operation in Sparse-Dense-Mode environment.

Comments:
All routers running OSPF
All routers running PIM-SDM.
R3 is the Auto RP and Mapping Agent.
224.0.1.39 - RP announcement.
224.0.1.40 - RP discovery.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.

Dynamips .net file and configurations


PIM-SM (Auto RP) (3)



Topology:


Purpose: Understand Auto RP Operation in Sparse-Mode Only environment.

Comments:
All routers running OSPF
All routers running PIM-SM.
R3 is the Auto RP and Mapping Agent.
R1 and R2 have as static RP R2 for group 224.0.1.40.
R4 and R5 have as static RP R4 for group 224.0.1.40.
224.0.1.39 - RP announcement.
224.0.1.40 - RP discovery.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.

Dynamips .net file and configurations


PIM-SM (BSR)



Topology:


Purpose: Understand Bootstrap Router Operation.

Comments:
All routers running OSPF
All routers running PIM-SM.
R3 is the Candidate RP and BSR.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.

Dynamips .net file and configurations


PIM SSM



Topology:


Purpose: Understand Source Specific Multicast Operation.

Comments:
All routers running OSPF
All routers running PIM-SDM.
IGMPv3 between R5 and HOST2.
HOST1 sends traffic to 232.1.1.1.
HOST2 joins group (10.10.10.1, 232.1.1.1).
(S, G) entries in every router.

Dynamips .net file and configurations


PIM BIDIR (Static RP)



Topology:


Purpose: Understand Bidirectional PIM Operation with Static Rendezvous Point.

Comments:
All routers running OSPF
All routers running PIM-SM.
R3 is the RP.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.
HOST2 sends traffic to 224.1.1.1.
HOST1 joins group 224.1.1.1.
(*, G) entries in every router.

Dynamips .net file and configurations


RP Anycast (Static RP)



Topology:


Purpose: Understand Anycast RP Operation with Static Rendezvous Point.

Comments:
All routers running OSPF
All routers running PIM-SM.
R2 and R4 are the RP's.
MSDP between R2 and R4.
HOST1 sends traffic to 224.1.1.1.
HOST2 joins group 224.1.1.1.

Dynamips .net file and configurations


PIM Security (1)



Topology:


Purpose: Understand PIM accept-rp and accept-register filtering options.

Comments:
All routers running OSPF
All routers running PIM-SDM.
R3 is the Auto RP and Mapping Agent.
HOST2 joins groups 224.1.1.1, 224.2.2.2, 224.3.3.3, 224.4.4.4.
R5 accept-rp for groups 224.1.1.1, 224.2.2.2, 224.3.3.3.
R4 accept-rp for groups 224.1.1.1, 224.2.2.2.
R3 accept-rp for group 224.1.1.1.
R3 accept-register for group 224.1.1.1.
HOST1 is only able to send traffic to 224.1.1.1.

Dynamips .net file and configurations


PIM Security (2)



Topology:


Purpose: Understand PIM rp-announce-filter filtering option.

Comments:
All routers running OSPF
All routers running PIM-SDM.
R2 is the Auto RP for groups 224.1.1.1 and 224.2.2.2.
R4 is the Auto RP for groups 224.1.1.1 and 224.2.2.2.
R3 is the Mapping Agent.
R3 accepts R2 as the RP for group 224.1.1.1.
R3 accepts R4 as the RP for group 224.2.2.2.

Dynamips .net file and configurations


PIM Security (3)



Topology:


Purpose: Preventing Dense Mode Fallback.

Comments:
All routers running OSPF
All routers running PIM-SDM.
There is no RP available.
R1 configured with "no ip pim dm-fallback".
HOST2 joins group 224.1.1.1.
HOST1 is not able to send traffic to 224.1.1.1.

Dynamips .net file and configurations


PIM Auto-RP Filter



Topology:


Purpose: PIM Auto-RP Filter with ACLs.

Dynamips .net file and configurations


Interdomain Multicast (MSDP)



Topology:


Purpose: Use MSDP to join two PIM-SM domains.

Comments:
All routers running OSPF
All routers running PIM-SM.
R1,R2,R3 with R3 as the RP.
R4,R5,R6 with R4 as the RP.
MSDP between R3 and R4.
The receiver R6 gets traffic from the source R1.

Dynamips .net file and configurations


Interdomain Multicast (MSDP+MBGP)



Topology:


Purpose: Use MSDP to join two PIM-SM domains and MBGP to perform RPF check.

Comments:
R1,R2,R3 running OSPF
R4,R5,R6 running IS-IS.
All routers running PIM-SM.
R1,R2,R3 with R3 as the RP.
R4,R5,R6 with R4 as the RP.
MSDP between R3 and R4.
BGP between R3 and R4 since R4 needs to join R3.
MBGP between R3 and R4 to avoid RPF failure.
The receiver R6 gets traffic from the source R1.

Dynamips .net file and configurations


Interdomain Multicast (MSDP+MRoute)



Topology:


Purpose: Use MSDP to join two PIM-SM domains and MRoute to override RPF failures.

Dynamips .net file and configurations


Cell Mode MPLS



Topology:


Purpose: Play with mpls atm control-vc and mpls atm vpi.

Dynamips .net file and configurations


Back-to-back Cell Mode MPLS



Topology:


Purpose: Cell Mode MPLS with routers connected back-to-back.

Dynamips .net file and configurations


Cell Mode MPLS over VCs



Topology:


Purpose: Cell Mode MPLS with ATM PVC.

Dynamips .net file and configurations


Frame Mode MPLS



Topology:


Purpose: Basic MPLS over ATM PVCs configuration.

Dynamips .net file and configurations


MPLS MTU



Topology:


Purpose: MTU issues in MPLS networks.

Dynamips .net file and configurations


MPLS NetFlow



Topology:


Purpose: MPLS-aware NetFlow and MPLS Egress NetFlow.

Comments:
Verification with "show ip cache verbose flow", "show mpls interface internal", "show mpls forwarding-table detail"

Dynamips .net file and configurations


BGP Free Core



Topology:


Purpose: Basic MPLS usage.

Dynamips .net file and configurations


MPLS Static Labels



Topology:


Purpose: Dynamic and Static Labels in MPLS.

Comments:
R1,R2,R3 running OSPF.
R1 uses dynamic label range 100-199.
R3 uses dynamic label range 300-399.
R2 uses dynamic label range 2000-2999.
R2 assigns static labels to R1 and R3 loopbacks.

Dynamips .net file and configurations


LDP Label Filtering



Topology:


Purpose: Inbound/Outbound Label Binding Filtering.

Dynamips .net file and configurations


LDP Advertise Label



Topology:


Purpose: Control Label Advertisement.

Dynamips .net file and configurations


LDP Session Protection



Topology:


Purpose: Faster LDP convergence when a link recovers following an outage.

Dynamips .net file and configurations


MPLS TE



Topology:


Purpose: TE tunnel between PE1 and PE3.

Dynamips .net file and configurations


MPLS Traffic Engineering: Load Sharing



Topology:


Purpose: MPLS TE Unequal-Cost Load Sharing.

Comments:
Traffic from R1 to R5 uses paths through R2,R3 and R4 with a 1:2:3 ratio.

Dynamips .net file and configurations


MPLS Traffic Engineering: Affinity



Topology:


Purpose: MPLS TE Affinity.

Comments:
Traffic from R1 to R5 uses paths through R2,R3 and R4 with a 1:2:3 ratio.

Dynamips .net file and configurations


MPLS Traffic Engineering: Interarea Tunnels (OSPF)



Topology:


Purpose: TE tunnel between R1 and R4.

Dynamips .net file and configurations


MPLS Traffic Engineering: Interarea Tunnels (IS-IS)



Topology:


Purpose: TE tunnel between R1 and R4.

Comments:
L1 routers R1 and R4 have reachability between them via the MPLS TE Tunnels.

Dynamips .net file and configurations


MPLS Traffic Engineering: Optimization (1)



Topology:


Purpose: MPLS TE Optimization.

Comments:
Dynamic Path is chosen after Explicit Path is down.
When Explicit Path is up again, it preempts Dynamic Path within 60 seconds.

Dynamips .net file and configurations


MPLS Traffic Engineering: Optimization (2)



Topology:


Purpose: MPLS TE Optimization.

Comments:
R1 sends traffic over TUNNEL1 due to lower metric.

Dynamips .net file and configurations


MPLS Traffic Engineering: Optimization (3)



Topology:


Purpose: MPLS TE Optimization.

Comments:
R1 sends traffic over TUNNEL1 due to higher priority.
TUNNEL2 will only come up if TUNNEL1 goes down.

Dynamips .net file and configurations


MPLS Traffic Engineering: Forwarding Adjacency (IS-IS)



Topology:


Purpose: MPLS TE Forwarding Adjacency.

Comments:
R1 uses both R2 and R5 to send traffic to R7.
R7 uses both R4 and R6 to send traffic to R1.

Dynamips .net file and configurations


MPLS Traffic Engineering: Forwarding Adjacency (OSPF)



Topology:


Purpose: MPLS TE Forwarding Adjacency.

Comments:
R1 uses both R2 and R5 to send traffic to R7.
R7 uses both R4 and R6 to send traffic to R1.

Dynamips .net file and configurations


MPLS VPN TE



Topology:


Purpose: TE tunnel between PE1 and P2. We need labels to avoid PHP problem.

Dynamips .net file and configurations


MPLS Multipath



Topology:


Purpose: BGP Multipath Load Sharing for Both eBGP and iBGP in an MPLS-VPN.

Comments:
CE2 is multihomed to PE2 and PE3.
P is a vpnv4 route-reflector.
PE1 installs both routes from PE2 and PE3.
Traffic from CE1 to CE2 goes through PE2 and PE3 in a per-packet fashion.

Dynamips .net file and configurations


Route Leaking



Topology:


Purpose: Understand route leaking from a vrf to global and from global to a vrf.

Dynamips .net file and configurations


Route Leaking Between VRFs



Topology:


Purpose: Understand route leaking between different VRFs.

Comments:
CE1 and CE2 have full reachability between them.

Dynamips .net file and configurations


Redistribution inside a VRF



Topology:


Purpose: Redistribution at the VRF Level.

Dynamips .net file and configurations


PE-CE Routing (Static)



Topology:


Purpose: Static routing between PE and CE.

Comments:
Cell-Mode MPLS in the Core.

Dynamips .net file and configurations


PE-CE Routing (RIPv2)



Topology:


Purpose: RIPv2 between PE and CE.

Comments:
Cell-Mode MPLS in the Core.

Dynamips .net file and configurations


PE-CE Routing (RIPv2 Sub-Optimal Routing)



Topology:


Purpose: Sub-optimal routing due to backdoor link presence.

Comments:
TE Tunnels between PE1 and PE2.
Traffic flow is CE1->PE1->CE3->CE4->PE2->CE2.

Dynamips .net file and configurations


PE-CE Routing (RIPv2 Optimal Routing)



Topology:


Purpose: Optimal routing with BGP COST-COMMUNITY and DISTANCE COMMAND.

Comments:
TE Tunnels between PE1 and PE2.
Traffic flow is CE1->PE1->P->PE2->CE2.

Dynamips .net file and configurations


PE-CE Routing (EIGRP Same AS)



Topology:


Purpose: EIGRP between PE and CE when the AS is the same on the PE routers.

Comments:
CE1 sees CE2 routes as D.
CE2 sees CE1 routes as D.

Dynamips .net file and configurations


PE-CE Routing (EIGRP Different AS)



Topology:


Purpose: EIGRP between PE and CE when the AS is different on the PE routers.

Comments:
CE1 sees CE2 routes as D EX.
CE2 sees CE1 routes as D EX.

Dynamips .net file and configurations


PE-CE Routing (EIGRP Sub-Optimal Routing)



Topology:


Purpose: Sub-optimal routing due to backdoor link presence.

Comments:
Traffic flow is CE1->PE1->CE3->CE4->PE2->CE2.

Dynamips .net file and configurations


PE-CE Routing (EIGRP Site of Origin)



Topology:


Purpose: Optimal routing using EIGRP SoO.

Comments:
SoO configured on PE1 interface facing CE3 (soo=3:3).
SoO configured on PE2 interface facing CE4 (soo=4:4).
SoO configured on CE3 interface facing CE4 (soo=3:3).
SoO configured on CE4 interface facing CE3 (soo=4:4).
Traffic flow is CE1->PE1->P->PE2->CE2.
Doesn't work with 12.2S. It works with 12.0S.

Dynamips .net file and configurations


PE-CE Routing (OSPF Same Process ID)



Topology:


Purpose: OSPF between PE and CE when the Process ID is the same on the PE routers.

Comments:
Intra-Area routes seen as Inter-Area routes.

Dynamips .net file and configurations


PE-CE Routing (OSPF Different Process ID)



Topology:


Purpose: OSPF between PE and CE when the Process ID is different on the PE routers.

Comments:
Intra-Area routes seen as External Type-2 routes.

Dynamips .net file and configurations


PE-CE Routing (OSPF Domain-Id)



Topology:


Purpose: OSPF between PE and CE when the Process ID is different on the PE routers but the Domain-Id is the same.

Comments:
Intra-Area routes seen as Inter-Area routes.

Dynamips .net file and configurations


PE-CE Routing (OSPF Sub-Optimal Routing)



Topology:


Purpose: Sub-optimal routing due to backdoor link presence.

Comments:
Traffic flow is CE1->PE1->CE3->CE4->PE2->CE2.

Dynamips .net file and configurations


PE-CE Routing (OSPF Sham-Link)



Topology:


Purpose: Optimal routing using OSPF Sham-Link.

Comments:
Traffic flow is CE1->PE1->P->PE2->CE2.
Intra-Area routes seen as Intra-Area routes.

Dynamips .net file and configurations


Sham-Link Intra-AS



Topology:


Purpose: Sham-Link between PE's in the same AS.

Dynamips .net file and configurations


Sham-Link Intra-AS (2)



Topology:


Purpose: Sham-Link between PE's in the same AS.

Dynamips .net file and configurations


Sham-Link Inter-AS with eBGP



Topology:


Purpose: Sham-Link between PE's in different AS's.

Dynamips .net file and configurations


Sham-Link Inter-AS with iBGP



Topology:


Purpose: Sham-Link between PE's in different AS's.

Dynamips .net file and configurations


PE-CE Routing (IS-IS)



Topology:


Purpose: IS-IS used as the PE-CE routing protocol.

Comments:
CE1 and PE1 in area 49.0001 forming L1L2 adjacency.
CE2 and PE2 in area 49.0001 forming L1L2 adjacency.
Only supported in 12.0S.

Dynamips .net file and configurations


MPLS VPN: VRF Over GRE



Topology:


Purpose: VRF over GRE Tunnel.

Dynamips .net file and configurations


BGP Site of Origin



Topology:


Purpose: Test BGP SoO feature.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option A (Back-to-back VRF at the ASBRs)



Topology:


Purpose: Inter-AS MPLS VPN.

Comments:
PE1, P1 and PE2 are running OSPF and are AS1.
PE3, P2 and PE4 are running IS-IS and are AS2.
MPLS between PE1-P1-PE2 and PE3-P2-PE4.
PE2 and PE3 are the ASBRs.
We are using static routing in order to exchange VPN routes.
CE1 is able to reach CE2.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option B (VPNv4 route exchange between ASBRs)



Topology:


Purpose: Inter-AS MPLS VPN.

Comments:
PE1, P1 and PE2 are running OSPF and are AS1.
PE3, P2 and PE4 are running IS-IS and are AS2.
MPLS between PE1-P1-PE2 and PE3-P2-PE4.
PE2 and PE3 are the ASBRs.
"mpls bgp forwarding" is added automatically so no need to use "neighbor send-label".
CE1 is able to reach CE2.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option B (VPNv4 route exchange between ASBRs with Route-Target Rewrite)



Topology:


Purpose: Inter-AS MPLS VPN with Route-Target Rewrite.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange)



Topology:


Purpose: Inter-AS MPLS VPN.

Comments:
PE1, P1 and PE2 are running OSPF and are AS1.
PE3, P2 and PE4 are running IS-IS and are AS2.
MPLS between PE1-P1-PE2 and PE3-P2-PE4.
BGPipv4+Labels between PE2 and PE3.
BGPvpnv4 between P1 and P2.
CE1 is able to reach CE2.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange with Route-Target Rewrite)



Topology:


Purpose: Inter-AS MPLS VPN with Route-Target Rewrite.

Dynamips .net file and configurations


Inter-AS MPLS VPNs Option C (Multihop VPNv4 route exchange with Route-Target Rewrite)



Topology:


Purpose: Inter-AS MPLS VPN with Route-Target Rewrite.

Dynamips .net file and configurations


Carrier Supporting Carrier: Customer Carrier Not Running MPLS



Topology:


Purpose: Carrier Supporting Carrier.

Comments:
The 9 routers are 7200's running 12.0(32)S9.

Dynamips .net file and configurations


Carrier Supporting Carrier: Customer Carrier Running MPLS



Topology:


Purpose: Carrier Supporting Carrier.

Comments:
The 9 routers are 7200's running 12.0(32)S9.

Dynamips .net file and configurations


Carrier Supporting Carrier: Customer Carrier Providing MPLS VPN Service



Topology:


Purpose: Carrier Supporting Carrier.

Comments:
The 9 routers are 7200's running 12.0(32)S9.

Dynamips .net file and configurations


Carrier Supporting Carrier: Customer Carrier Providing MPLS VPN Service (2)



Topology:


Purpose: Carrier Supporting Carrier.

Comments:
The 7 routers are 7200's running 12.0(32)S9.

Dynamips .net file and configurations


VRF Select



Topology:


Purpose: Directing MPLS VPN Traffic Based on Source IP Address.

Comments:
PE-CE routing is static.
CE1 traffic from lo12 goes to VPN12.
CE1 traffic from lo13 goes to VPN13.
CE1 traffic from other sources is dropped.
CE2 lo12 in VPN12.
CE3 lo13 in VPN13.
CE1 lo12 is able to reach CE2 lo12.
CE1 lo13 is able to reach CE3 lo13.

Dynamips .net file and configurations


VRF Selection with PBR



Topology:


Purpose: Directing MPLS VPN Traffic Using Policy-Based Routing.

Comments:
PE-CE routing is static.
CE1 traffic from lo12 goes to VPN12.
CE1 traffic from lo13 goes to VPN13.
CE1 traffic from other sources is dropped.
CE2 lo12 in VPN12.
CE3 lo13 in VPN13.
CE1 lo12 is able to reach CE2 lo12.
CE1 lo13 is able to reach CE3 lo13.

Dynamips .net file and configurations


VRF Lite



Topology:


Purpose: VRF Lite Feature at Customer Edge Router.

Comments:
CE1 assigns lo12 and s1/0 to VPN12.
CE1 assigns lo13 and s1/2 to VPN13.
CE1 runs ripv2 with PE1.
CE2 in VPN12 via static/connected.
CE3 in VPN13 via static/connected.
CE1's VPN12 vrf has reachability to CE2.
CE1's VPN13 vrf has reachability to CE3.

Dynamips .net file and configurations


Multicast VPN (with SSM in the Core)



Topology:


Purpose: MDT and SSM usage.

Comments:
The CE's are running PIM-SM with CE1 as the RP.
The PE's are transporting the VPN Multicast traffic via MDT.
To transport the MDT traffic, we are using SSM.
CE1 is the receiver.
CE2, CE3 and CE4 are able to send traffic to the receiver.

Dynamips .net file and configurations


Multicast VPN (with SM in the Core)



Topology:


Purpose: MDT and SM usage.

Comments:
The CE's are running PIM-SM with CE1 as the RP.
The PE's are transporting the VPN Multicast traffic via MDT.
The PE's are running PIM-SM with P as the RP.
To transport the MDT traffic, we are using SM.
CE1 is the receiver.
CE2, CE3 and CE4 are able to send traffic to the receiver.

Dynamips .net file and configurations


Multicast VPN with Multiple PE's



Topology:


Purpose: Multicast VPN with 3 PE's and 3 CE's.

Dynamips .net file and configurations


Inter-AS Multicast VPNs Option A (Back-to-back VRF at the ASBRs)



Topology:


Purpose: Inter-AS Multicast VPNs.

Comments:
PE1, P1 and PE2 are running OSPF and are AS1.
PE3, P2 and PE4 are running IS-IS and are AS2.
MPLS between PE1-P1-PE2 and PE3-P2-PE4.
PE2 and PE3 are the ASBRs.
We are using static routing in order to exchange VPN routes.
VRF BLUE is running PIM-SM with CE1 as the static RP.
PE1, P1 and PE2 form MDT 224.1.1.1.
PE3, P3 and PE4 form MDT 224.2.2.2.
CE1 is able to reach CE2 (ping 20.20.20.2).
CE1 is able to reach CE2 (ping 224.3.3.3).

Dynamips .net file and configurations


Inter-AS Multicast VPNs Option C (VPNv4 between RR's)



Topology:


Purpose: Inter-AS Multicast VPNs.

Dynamips .net file and configurations


Inter-AS Multicast VPNs Option C (VPNv4 between PE's)



Topology:


Purpose: Inter-AS Multicast VPNs.

Dynamips .net file and configurations


Dynamic L3-VPNs over mGRE



Topology:


Purpose: L3-VPNs over mGRE.

Comments:
Only available with 12.0S.
PE1, P and PE2 are running OSPF.
PE1 is in AS100.
PE2 is in AS200.
PE1 and PE2 are running mGRE.
CE1 is able to reach CE2.

Dynamips .net file and configurations


Dynamic L3-VPNs over L2TPv3



Topology:


Purpose: L3-VPNs over L2TPv3.

Comments:
Only available with 12.0S.
PE1, P and PE2 are running OSPF.
PE1 is in AS100.
PE2 is in AS200.
PE1 and PE2 are running L2TPv3.
CE1 is able to reach CE2.

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Router to Router Port Mode)



Topology:


Purpose: Basic EoMPLS (Router to Router Port Mode) configuration.

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Router to Router Vlan Mode)



Topology:


Purpose: Basic EoMPLS (Router to Router Vlan Mode) configuration.

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Router to Router Vlan Rewrite)



Topology:


Purpose: Basic EoMPLS (Router to Router Vlan Rewrite) configuration.

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Switch to Switch Vlan Mode)



Topology:


Purpose: Basic EoMPLS (Switch to Switch Vlan Mode) configuration.

Comments:
Not possible to achieve with Dynamips.
12.4T running on all devices.

Additional configuration missing:
PE1:
!
interface Vlan10
xconnect 2.2.2.2 100 encapsulation mpls
!
PE2:
!
interface Vlan10
xconnect 1.1.1.1 100 encapsulation mpls
!

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Switch to Switch Port Mode - QinQ)



Topology:


Purpose: Basic EoMPLS (Switch to Switch Port Mode - QinQ) configuration.

Comments:
Not possible to achieve with dynamips.
12.4T running on all devices.

Additional configuration missing:
PE1:
!
vlan dot1q tag native
!
interface FastEthernet1/0
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
spanning-tree bpdufilter enable
!
interface Vlan100
xconnect 2.2.2.2 100 encapsulation mpls
!
PE2:
!
vlan dot1q tag native
!
interface FastEthernet1/0
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
spanning-tree bpdufilter enable
!
interface Vlan100
xconnect 1.1.1.1 100 encapsulation mpls
!

Dynamips .net file and configurations


AToM - Ethernet over MPLS (Switch to Switch Port Mode - Native)



Topology:


Purpose: Basic EoMPLS (Switch to Switch Port Mode - Native) configuration.

Comments:
12.4T running on all devices.

Dynamips .net file and configurations


AToM - Frame Relay over MPLS



Topology:


Purpose: Basic FRoMPLS configuration.

Dynamips .net file and configurations


AToM - Frame Relay over MPLS with a Frame-Relay Switch



Topology:


Purpose: Basic FRoMPLS configuration using a Frame-Relay Switch.

Dynamips .net file and configurations


AToM - Port-Mode Frame Relay over MPLS



Topology:


Purpose: Basic Port-Mode FRoMPLS configuration.

Dynamips .net file and configurations


AToM - PPP over MPLS



Topology:


Purpose: Basic PPPoMPLS configuration.

Dynamips .net file and configurations


AToM - HDLC over MPLS



Topology:


Purpose: Basic HDLCoMPLS configuration.

Dynamips .net file and configurations


AToM - ATM over MPLS (AAL5)



Topology:


Purpose: Basic ATMoMPLS (AAL5) configuration.

Comments:
Not possible to achieve with Dynamips.

Additional configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal5
xconnect 2.2.2.2 100 encapsulation mpls
!
PE2:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal5
xconnect 1.1.1.1 100 encapsulation mpls
!

Dynamips .net file and configurations


AToM - ATM over MPLS (Cell Relay)



Topology:


Purpose: Basic ATMoMPLS (Cell Relay) configuration.

Comments:
Not possible to achieve with Dynamips.

Additional configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal0
xconnect 2.2.2.2 100 encapsulation mpls
!
PE2:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal0
xconnect 1.1.1.1 100 encapsulation mpls
!

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Router to Router Port Mode)



Topology:


Purpose: Basic EoL2TPv3 (Router to Router Port Mode) configuration.

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Router to Router Vlan Mode)



Topology:


Purpose: Basic EoL2TPv3 (Router to Router Vlan Mode) configuration.

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Router to Router Vlan Rewrite)



Topology:


Purpose: Basic EoL2TPv3 (Router to Router Vlan Rewrite) configuration.

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Vlan Mode)



Topology:


Purpose: Basic EoL2TPv3 (Switch to Switch Vlan Mode) configuration.

Comments:
12.4 running on all devices.

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Port Mode - QinQ)



Topology:


Purpose: Basic EoL2TPv3 (Switch to Switch Port Mode - QinQ) configuration.

Comments:
Not possible to achieve with dynamips.
12.4 running on all devices.

Additional configuration missing:
PE1:
!
vlan dot1q tag native
!
interface FastEthernet1/0
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
spanning-tree bpdufilter enable
!
PE2:
!
vlan dot1q tag native
!
interface FastEthernet1/0
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
spanning-tree bpdufilter enable
!

Dynamips .net file and configurations


L2TPv3 - Ethernet over L2TPv3 (Switch to Switch Port Mode - Native)



Topology:


Purpose: Basic EoL2TPv3 (Switch to Switch Port Mode - Native) configuration.

Comments:
12.4 running on all devices.

Dynamips .net file and configurations


L2TPv3 - Frame Relay over L2TPv3



Topology:


Purpose: Basic FRoL2TPv3 configuration.

Dynamips .net file and configurations


L2TPv3 - PPP over L2TPv3



Topology:


Purpose: Basic PPPoL2TPv3 configuration.

Dynamips .net file and configurations


L2TPv3 - HDLC over L2TPv3



Topology:


Purpose: Basic HDLCoL2TPv3 configuration.

Dynamips .net file and configurations


L2TPv3 - ATM over L2TPv3 (AAL5)



Topology:


Purpose: Basic ATMoL2TPv3 (AAL5) configuration.

Comments:
Not possible to achieve with Dynamips.

Additional configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal5
xconnect 2.2.2.2 100 pw-class PSEUDOWIRE-CLASS
!
PE2:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal5
xconnect 1.1.1.1 100 pw-class PSEUDOWIRE-CLASS
!

Dynamips .net file and configurations


L2TPv3 - ATM over L2TPv3 (Cell Relay)



Topology:


Purpose: Basic ATMoL2TPv3 (Cell Relay) configuration.

Comments:
Not possible to achieve with Dynamips.

Additional configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal0
xconnect 2.2.2.2 100 pw-class PSEUDOWIRE-CLASS
!
PE2:
!
interface ATM1/0.1 point-to-point
pvc 0/100 l2transport
encapsulation aal0
xconnect 1.1.1.1 100 pw-class PSEUDOWIRE-CLASS
!

Dynamips .net file and configurations


Interworking: Ethernet-to-VLAN using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK, IPv6 OK.

Dynamips .net file and configurations


Interworking: Ethernet-to-VLAN using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK.

Dynamips .net file and configurations


Interworking: FR-to-VLAN using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK WITH IRB.

Dynamips .net file and configurations


Interworking: FR-to-VLAN using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK.
Use IRDP in CE2.

Dynamips .net file and configurations


Interworking: PPP-to-VLAN using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
DOES NOT WORK.

Dynamips .net file and configurations


Interworking: PPP-to-VLAN using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK.
Use IRDP in CE2.

Dynamips .net file and configurations


Interworking: ATM-to-VLAN using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 2.2.2.2 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: ATM-to-VLAN using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 2.2.2.2 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: FR-to-PPP using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
DOES NOT WORK.

Dynamips .net file and configurations


Interworking: FR-to-PPP using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
IPv4 OK.

Dynamips .net file and configurations


Interworking: FR-to-ATM using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: FR-to-ATM using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: PPP-to-ATM using AToM (bridged)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: PPP-to-ATM using AToM (routed)



Topology:


Purpose: Interworking with AToM.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: Ethernet-to-VLAN using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK, IPv6 OK.

Dynamips .net file and configurations


Interworking: Ethernet-to-VLAN using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK.

Dynamips .net file and configurations


Interworking: FR-to-VLAN using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK WITH IRB.

Dynamips .net file and configurations


Interworking: FR-to-VLAN using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK.
Use IRDP in CE2.

Dynamips .net file and configurations


Interworking: PPP-to-VLAN using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
DOES NOT WORK.

Dynamips .net file and configurations


Interworking: PPP-to-VLAN using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK.
Use IRDP in CE2.

Dynamips .net file and configurations


Interworking: ATM-to-VLAN using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 2.2.2.2 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: ATM-to-VLAN using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 2.2.2.2 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: FR-to-PPP using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
DOES NOT WORK.

Dynamips .net file and configurations


Interworking: FR-to-PPP using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
IPv4 OK.

Dynamips .net file and configurations


Interworking: FR-to-ATM using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: FR-to-ATM using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: PPP-to-ATM using L2TPv3 (bridged)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE2:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Interworking: PPP-to-ATM using L2TPv3 (routed)



Topology:


Purpose: Interworking with L2TPv3.

Comments:
Not possible to achieve with dynamips.

Configuration missing:
PE1:
!
interface ATM1/0.1 point-to-point
mtu 1500
pvc 0/100 l2transport
xconnect 1.1.1.1 100 pw-class INTERWORKING
!

Dynamips .net file and configurations


Local Switching: Ethernet-to-Ethernet



Topology:


Purpose: Local Switching.

Comments:
IPv4 OK, IPv6 OK

Dynamips .net file and configurations


Local Switching: VLAN-to-VLAN



Topology:


Purpose: Local Switching.

Comments:
IPv4 OK, IPv6 OK

Dynamips .net file and configurations


Local Switching: FR-to-FR



Topology:


Purpose: Local Switching.

Comments:
IPv4 OK, IPv6 OK

Dynamips .net file and configurations


Local Switching: ATM-to-ATM



Topology:


Purpose: Local Switching.

Comments:
Not possible to achieve.

Configuration missing:
PE:
!
interface ATM1/0
pvc 0/100 l2transport
encapsulation aal5
!
interface ATM2/0
pvc 0/200 l2transport
encapsulation aal5
!
connect LOCAL-SWITCHING atm 1/0 0/100 atm 2/0 0/200
!

Dynamips .net file and configurations


Local Switching with Interworking: Ethernet-to-VLAN (bridged)



Topology:


Purpose: Local Switching with Interworking.

Comments:
IPv4 OK, IPv6 OK.

Dynamips .net file and configurations


Local Switching with Interworking: Ethernet-to-VLAN (routed)



Topology:


Purpose: Local Switching with Interworking.

Comments:
IPv4 OK.

Dynamips .net file and configurations


Local Switching with Interworking: FR-to-VLAN (bridged)



Topology:


Purpose: Local Switching with Interworking.

Comments:
IPv4 OK WITH IRB.

Dynamips .net file and configurations


Local Switching with Interworking: FR-to-VLAN (routed)



Topology:


Purpose: Local Switching with Interworking.

Comments:
IPv4 OK.

Dynamips .net file and configurations


AToM - Inter-AS L2-VPNs (Pseudo-Wire Switching)



Topology:


Purpose: Inter-AS L2-VPNs.

Comments:
Available in the 3725's running 12.4T.
PE1 and P1 running OSPF and MPLS.
PE2 and P2 running OSPF and MPLS.
P1 in AS1.
P2 in AS2.
BGPipv4+label between P1 and P2.
xconnect from PE1 to P1.
xconnect from PE2 to P2.
pseudo-wire switching in P1 (PE1<->P2).
pseudo-wire switching in P2 (PE2<->P1).
CE1 is able to reach CE2.

Dynamips .net file and configurations


AToM - L3VPNs over L2VPNs



Topology:


Purpose: L3VPNs over L2VPNs.

Comments:
PE1 and PE2 running OSPF, MPLS and L3VPNs.
P1 and P2 running OSPF, MPLS and L2VPNs.
CE1 is able to reach CE2.

Dynamips .net file and configurations


MPLS VPN QoS (Uniform Mode)



Topology:


Purpose: MPLS DiffServ Uniform Tunneling Mode.

Comments:
CE1 sends ICMP with IPP=5.
PE1 dinamically sets the top-most label EXP from the IPP value.
P1 marks down top-most label from EXP=5 to EXP=3.
P3 pops top-most label and dinamically copies its EXP to underlying label.
PE2 dinamically sets IPP from the received EXP value.
CE2 receives ICMP with IPP=3.

Dynamips .net file and configurations


MPLS VPN QoS (Pipe Mode)



Topology:


Purpose: MPLS DiffServ Pipe Tunneling Mode.

Comments:
CE1 sends ICMP with IPP=5.
P1 marks down top-most label from EXP=5 to EXP=3.
P3 pops top-most label and dinamically copies its EXP to underlying label.
CE2 receives ICMP with IPP=5.

Dynamips .net file and configurations


MPLS VPN QoS (Implicit Null)



Topology:


Purpose: Verify problem PHP can bring to MPLS QoS.

Comments:
CE1 sends ICMP with IPP=5.
PE1 sets imposition label with EXP=0 and top-most label with EXP=5.
P1 pops top-most label and exposes underlying label with EXP=0.
PE2 dinamically sets IPP from the received EXP value.
CE2 receives ICMP with IPP=0.

Dynamips .net file and configurations


MPLS VPN QoS (Explicit Null)



Topology:


Purpose: Avoid PHP problem in MPLS QoS will Explicit-Null Labeling.

Comments:
CE1 sends ICMP with IPP=5.
PE1 sets imposition label with EXP=0 and top-most label with EXP=5.
P1 swaps top-most label with explicit-null label maintaining EXP=5.
PE2 dinamically sets IPP from the received EXP value.
CE2 receives ICMP with IPP=5.

Dynamips .net file and configurations


MPLS VPN QoS (Explicit-Null at the Managed CE)



Topology:


Purpose: MPLS Label Imposition and EXP Marking done at the CE.

Comments:
CE1 sends ICMP traffic with IPP=0.
CE1 sets explicit-null label with EXP=5.
PE2 dinamically sets IPP from the received EXP value.
CE2 receives ICMP with IPP=5.

Dynamips .net file and configurations


MPLS VPN QoS (Traffic Engineering)



Topology:


Purpose: Label stack with 3 different MPLS EXP.

Comments:
TE Tunnel between P1 and P3.
LDP adjacency between P1 and P3 in order to avoid PHP problem.
PE1 sets VPN label with EXP=0.
PE1 sets next-hop label with EXP=1.
P1 sets TE label with EXP=2.

Dynamips .net file and configurations


QoS Nested Policy-Maps



Topology:


Purpose: Nested Policy-Maps up to 3 levels.

Dynamips .net file and configurations


QoS Rate Limit Continue



Topology:


Purpose: Rate-Limit continue example.

Dynamips .net file and configurations


QoS IP SLA



Topology:


Purpose: Generate traffic in R1 and drop it in R2.

Dynamips .net file and configurations


RSVP



Topology:


Purpose: RSVP Reservations made by the routers.

Dynamips .net file and configurations


uRPF (Old Style)



Topology:


Purpose: Understand Unicast Reverse Path Forwarding.

Comments:
R1, R2 and R3 running OSPF.
R2 and R3 loopbacks in OSPF.
R1 uses same loopback as R2 but it's not advertised.
Effect of each ACL applied to uRPF when a ping is sourced from R1-lo0 to R3-lo0:
access-list 1 permit any [FORWARD]
access-list 2 permit any log [FORWARD, LOG]
access-list 3 deny any [DROP]
access-list 4 deny any log [DROP, LOG]
access-list 100 permit ip any any [FORWARD]
access-list 101 permit ip any any log [FORWARD, LOG]
access-list 102 permit ip any any log-input [FORWARD, LOG-INPUT]
access-list 103 deny ip any any [DROP]
access-list 104 deny ip any any log [DROP, LOG]
access-list 105 deny ip any any log-input [DROP, LOG-INPUT]

Dynamips .net file and configurations


uRPF (New Style)



Topology:


Purpose: Understand Unicast Reverse Path Forwarding.

Comments:
R1, R2 and R3 running OSPF.
R2 and R3 loopbacks in OSPF.
R1 uses same loopback as R2 but it's not advertised.
Effect of each ACL applied to uRPF when a ping is sourced from R1-lo0 to R3-lo0:
access-list 1 permit any [FORWARD]
access-list 2 permit any log [FORWARD, LOG]
access-list 3 deny any [DROP]
access-list 4 deny any log [DROP, LOG]
access-list 100 permit ip any any [FORWARD]
access-list 101 permit ip any any log [FORWARD, LOG]
access-list 102 permit ip any any log-input [FORWARD, LOG-INPUT]
access-list 103 deny ip any any [DROP]
access-list 104 deny ip any any log [DROP, LOG]
access-list 105 deny ip any any log-input [DROP, LOG-INPUT]

Dynamips .net file and configurations


Smurf



Topology:


Purpose: Understand what is a Smurf Attack.

Comments:
RTR is used to perform the attack.
Solutions are uRPF, ACL's, "no ip directed-broadcast".

Dynamips .net file and configurations


Fraggle



Topology:


Purpose: Understand what is a Fraggle Attack.

Comments:
RTR is used to perform the attack.
Solutions are uRPF, ACL's, "no ip directed-broadcast", "no service udp-small-servers".
The Amplifiers are not processing the UDP Echo packets sent to 255.255.255.255:echo.

Dynamips .net file and configurations


LDP/TDP ACL



Topology:


Purpose: Understand LDP and TDP session establishment.

Comments:
R1,R2,R3 running OSPF.
LDP between R1 and R2.
TDP between R2 and R3.
R2 only accepts R1 and R3 as neighbors.

Dynamips .net file and configurations


Remotely Triggered Black Hole (RTBH) Filtering Source-Based



Topology:


Purpose: Understand RTBH Filtering.

Dynamips .net file and configurations


Remotely Triggered Black Hole (RTBH) Filtering Destination-Based



Topology:


Purpose: Understand RTBH Filtering.

Dynamips .net file and configurations


Control Plane Policing (1)



Topology:


Purpose: Understand CoPP.

Comments:
R2 allows telnet from R1.
R3 allows telnet from R2.
Not available in 12.2T.

Dynamips .net file and configurations


Control Plane Policing (2)



Topology:


Purpose: Understand CoPP.

Comments:
R2 allows ping from R1.
R3 allows ping from R2.
Not available in 12.2T.

Dynamips .net file and configurations


Control Plane Policing (3)



Topology:


Purpose: Understand CoPP.

Comments:
R2 does not send time exceeded or port unreachable.
R1 and R3 are able to traceroute each other but R2 is invisible.

Dynamips .net file and configurations


QoS Policy Propagation with BGP (1)



Topology:


Purpose: Understand QPPB.

Comments:
Traffic from/to AS4 marked with IPP=4.
Traffic from/to AS5 marked with IPP=5.

Dynamips .net file and configurations


QoS Policy Propagation with BGP (2)



Topology:


Purpose: Understand QPPB.

Comments:
Traffic from/to AS4 marked with QOS-GROUP=4.
Traffic from/to AS5 marked with QOS-GROUP=5.

Dynamips .net file and configurations


HSRP



Topology:


Purpose: High availability with HSRP.

Comments:
R1,R2,R3,R4 running OSPF.
R1 is tracking the serial interface.
R3 is tracking the serial interface.
Standby mac is non-default.
Plain-text authentication is used.

Dynamips .net file and configurations


VRRP



Topology:


Purpose: High availability with VRRP.

Comments:
R1,R2,R3,R4 running OSPF.
R1 is tracking the serial interface.
R3 is tracking the serial interface.
MD5 authentication is used.

Dynamips .net file and configurations


GLBP



Topology:


Purpose: High availability and Load-Balancing with GLBP.

Comments:
R1,R2,R3,R4 running OSPF.
R1 is the AVG for AVF's R1-R2.
HOST1 uses R1 as Gw.
HOST2 uses R2 as Gw.
R4 is the AVG for AVF's R3-R4.
HOST3 uses R4 as Gw.
HOST4 uses R3 as Gw.
MD5 authentication is used.

Dynamips .net file and configurations


MPLS TE Fast ReRoute (FRR)



Topology:


Purpose: Fast ReRoute for link and node protection.

Comments:
Primary Path: PE1->P1->PE2.
Backup Path: PE1->P1->P2->PE2.
Protected Link: P1->PE2.

Dynamips .net file and configurations


SNMP



Topology:


Purpose: SNMP Traps.

Dynamips .net file and configurations


NTP



Topology:


Purpose: NTP with Authentication.

Dynamips .net file and configurations


SSH



Topology:


Purpose: SSH client and server.

Dynamips .net file and configurations


RMON



Topology:


Purpose: RMON Feature.

Dynamips .net file and configurations


IP Accounting



Topology:


Purpose: IP Accounting Feature.

Dynamips .net file and configurations


Netflow



Topology:


Purpose: Netflow Ingress interface and sub-interface support.

Dynamips .net file and configurations


Last Updated: 02-SEPTEMBER-2009